Till senaste kommentaren
Detta inlägg är gammalt och kan innehålla inaktuell information.
Kommentaren du söker har flyttats till en ny diskussion, eller är borttagen.

SiteId ibland tomt objekt och ibland ett riktigt värde

Hej,

jag använder mig av https://api.trafiklab.se/sl/storningsinfo/GetAl... för att plocka fram data angående störningar.

Men siteId blir ibland ett tomt objekt (ex: "aSiteId":{}) och ibland en sträng (ex: "aSiteId":"9000"). Det verkar vara lite slumpmässigt, för ställer man om frågan så kan siteId få rätt värde igen. Har även fått samma sak för LineNumber.

Får även samma fel om jag begär XML istället för JSON. Dessutom småjobbigt att parsa när det ibland är sträng och ibland ett objekt som svar.

Kommentarer

  • Hej!

    Jag gjorde ett anrop nu och fick inga tomma "aSiteId". "aSiteId" är ett hållplatsnummer där störningen är gällande och ska med andra ord inte vara tomt.

    Kvarstår problemet för dig så skriv gärna igen så får vi gräva mer i problemet.

    /Martin

    Team Trafiklab
  • Just nu verkar "aSiteId" dyka upp korrekt, men istället är det andra fält ("aDetails":{}) som inte blir rätt.

    Väldigt bökigt om man måste ta höjd för att tjänsten inte garanterar att data visas. Nu kanske inte aDetails är ett fält som alltid ska ha data, men kan inte se att något sådant tas upp i dokumentationen.

    Hade hellre sett att man får "aDetails": "" eller inte inkluderar aDetails över huvud taget när fältet är tomt.

  • Hej!

    Tack för feedbacken. "aDetails" ska alltid finnas med i svaret och det är bättre som du säger att det är en tom sträng "" än ett tomt objekt {}.
    Vi ska undersöka vad det beror på.

    Trevlig helg

    /Martin

    Team Trafiklab

Kommentera eller skriv ett nytt inlägg

Ditt namn och inlägg kan ses av alla. Din e-post visas aldrig publikt.