Kommentaren du söker har flyttats till en ny diskussion, eller är borttagen.

SVT Play hackar på Apple TV version 4

Hej! Jag har problem med min Apple TV version 4 när vi ska kolla på SVT Play. Alla andra appar på ATV:n fungerar, men det hackar något enormt med SVT Play.

Vad göra?

Mvh Jonas

Jonas Rapportera olämpligt innehåll
Visa bästa svaret

Kommentarer

  • Hej! Jag har samma problem. Alla appar (Netflix, iTunes Movie, YouTube) fungerar som det ska med bra bildkvalitet när Apple TV 4 är inställd i 1080p upplösning. SVTplay däremot droppar frames så bildupplevelsen blir ryckig. Problemet försvinner när jag ställer in Apple TV i 720p läget. Det kan inte bero på tillgänglig bandbredd då jag utan problem streamar Netflix 4K material direkt i TVn dessutom fungerar alla andra tjänster med 1080p upplösning.

    Snälla se över detta problem, att se på SVTplay på Apple TV 4 är inte ett alternativ längre. Ni får gärna kontakta mig direkt för ytterligare information!

    mvh
    David Sandin

    David Sandin
  • Samma för mig

    M
  • Hej, vi försöker återskapa det fel ni beskriver och undrar därför när felet uppstår. Är det i början, mitt i eller slutet av videon? Och blir det bättre om ni väntar ett tag? Om inte hur ofta växlar videokvaliteten.

    Tommie
  • Senast det inträffade var när jag såg första avsnittet av Tungvattnet. Det sker löpande under uppspelningen. Viktigt att belysa är att strömmen inte växlar videokvalitet utan den droppar bildrutor så att bilden rycker till. Det blev inte bättre över tid. Bilden rycker till ett par gånger per minut. Samma serie finns på Netflix som spelas upp korrekt i 1080p på Apple TV

    David Sandin
  • Det har inte med bandbredd att göra då alla andra appar funkar fint. Felet är att bilden fryser en millisekund varanann sekund ungefär, och det avhjälps genom att man drar ut sladden till ATV4 och efter denna omstart funkar allt fint igen. Detta är dock otroligt störigt att behöva göra. Som sagt framstår det mer som en inkompabilitet mellan filen och avkodningen. Kvaliteten på videon går inte ner och bandbredd finns som sagt. Återkom gärna om ni vill ha mer info kring detta.

    Rickard
  • Hej igen och tack för rapporterna, vi fortsätter felsökningen och undrar om andra appar som till exempel TV 4 fungerar bättre? Utöver det undrar vi vilken frekvens samt bildkvalitet ni har valt på era apparater.

    Tommie
  • En fråga till: Vi undrar också vad ni använder för tv-apparat och vilken modell det är. Om ni vet modellnummer får ni gärna ange det också.

    Tommie
  • TV4 play fungerar som det ska, även Apples egna filmer samt Netflix. Jag instämmer med Rickards kommentar ovan.

    Jag har en Samsung UE48JU6465 UHD-TV. Har testat att ändra frekvens mellan 50 och 60Hz men felet kvarstår. Ändrar jag Apple TVn från 1080p till 720p så försvinner problemet. Har även testat att byta hdmi port på TVn utan framgång.

    Eftersom alla andra appar fungerar så måste problemet vara isolerat till SVT appen.

    David Sandin
  • Min tv sitter på väggen så jag kan inte se exakt modellnummer men det är en Sony Bravia som är inköpt 2011. TV4-appen har jag inte märkt något strul med, dock använder jag den väldigt sällan då den kanalen mest producerar trams.

    Rickard
  • David, ändrade du till 720p i ATV-inställningarna eller går det att göra i appen? Jag har testat att ändra detta i ATV-inställningarna utan framgång...

    Rickard
  • Har liknande problem sedan någon vecka tillbaka. Bilden hackar. Det fungerade bra tidigare så länge jag körde på 1080p 50 Hz istället för 60 Hz, men nu har det börjat hacka även i 50 Hz. Andra appar som TV4 fungerar klockrent. Har en LG 50PK350.

    Andreas Åberg
  • Rickard, jag ändrade i ATV. Går inte att ändra i appen vad jag känner till.

    David Sandin
  • Jonas, David, Rickard och Andreas,

    Vi försöker reda ut det här problemet.

    • Ställ in Apple TV:n manuellt—via dess inställningar—till 1080p och 50hz.
    • Se till att TV:n också är manuellt inställd på detta.

    Kvarstår ryckigheten när ni ser på SVTs videoström?

    Det vi vet är att Apple TV:n inte klarar av att automatiskt ställa om mellan 60 och 50hz.

    Erik Tjernlund
  • Jag har också problem, det har hackat från första dagen, men senaste veckan har det blivit mycket värre. Alla andra appar funkar helt utmärkt. Det börjar bli minst sagt frustrerande.

    Viktor
  • Hej igen, har någon i tråden möjlighet att följa upp de frågor Erik Tjernlund ställde tidigare? Det vore väldigt bra att få svar på dem så att vi kan gå till botten med denna fråga.

    Tommie
  • Har hela tiden haft både min TV och Apple TV inställd på 1080p 50 hz. Det konstiga är att problemet verkar ha försvunnit för mig nu. Mitt problem kanske låg i sändningarna i sig (problemet hade jag i Rapport-sändningarna).

    Andreas Åberg
  • Hej igen, jag har nu själv försökt gå till botten med detta och tror mig ha kommit fram till orsaken. Har testat att köra ATVn i både 50Hz och 60Hz utan framgång. Den ryckiga bilden dök även upp på en film jag hyrde från iTunes nu i helgen. Efter att ha uttömt diverse forum på nätet så har jag kommit fram till att fenomenet uppstår i samband med uppspelning av material som är filmat i 24P i kombination med Samsungs bildförbättringstekning Auto Motion Plus. När jag stänger av denna så försvinner ryckigheten i bilden. Det är många TV apparater som inte klarar av att spela upp 24P utan att motion judder kan uppstå.

    http://www.rtings.com/tv/tests/movies/judder

    David Sandin
  • Kan flika in att Apple tv inte har stöd för 24p output överhuvudtaget. Så visst, sådant material kan hacka lite i panoreringar på Apple tv, men det jag upplevde med SVT play var betydligt mer märkbart. Har inte ändrat något men ändå har problemet försvunnit, måste varit något i bildstömmen som förändrats.

    Andreas Åberg
  • Senaste versionen av Apple TV OS (9.2) Problemet kvarstår.
    AppleTv inställd på 1080p auto (vilket då blir 60 Hz) - vilket jag vet inte är optimalt då SVT:s sändningar är i 50 Hz (25?). Men ryckigheten motsvarar inte konvertering från 50/25 till 60 Hz. AppleTV kopplad till Onkyo Receiver Onkyo TX-NR545. TV:n är Sony Bravia KDL48R553BAE

    Vi ser mest på barnprogram, tex Robin Hoods rabalder. För det mesta fungerar det bra.
    Ljudet fungerar alltid utmärkt, men bilden blir ibland ryckig (mer än konvertering från 50 Hz till 60 Hz borde ge).

    Ibland blir bilden väldigt långsam och halkar efter ljudet mer och mer så att det kan skilja tiotals sekunder i synk. Pausar man i det läget så stannar ljudet men bilden fortsätter en lång stund för att komma ikapp. Jag tror inte att det är TV:ns bildförbättringar som orsakar det lagget.

    M
  • Problem för mig med. Tycker det har blivit sämre senaste veckan. Förut gick bilden bara långsamt, nu stannar den ofta men ljudet fortsätter. Jag ska pröva ändra enligt era tips och återkomma. Prövade stänga av Motion Plus men såg ingen skillnad. Vad är 24p, är allt på SVT filmat i det formatet?

    Anna-Karin
  • Svar till Anna-Karin: SVTs material har 50p (frames/second) som orginalformat. När vi kodar det online blir det 25. Hz (herz) är uppdateringsfrekvensen på skärmen. Eftersom 25 är delbart med 50 ska vårt material funka bäst med 50hz.

    Hör gärna av dig när du har testat våra tips!

    Fråga till M: Kan du testa med att koppla Apple TV direkt till TVn (inte via Onkyon) och berätta här om det gjorde någon skillnad?

    Fråga till Viktor: Har du testat tipsen från vår utvecklare?

    Harald
  • Jag har testat era förslag till lösningar utan framgång. Efter att ha läst andras beskrivningar av problemet känns det i vissa fall som att den här tråden har avvikit från ursprungsproblemet, även om källan till felen kan vara densamma. Det känns viktigt att poängtera att felet dyker upp mitt under pågående uppspelningen av en video, och att den enda identifierade lösningen är att starta om ATV:en. Det är inga andra appar som har detta problem, oavsett om man sätter ATV:en på 50hz eller auto. Något delay mellan ljud och bild har jag inte noterat (annat problem som skall ha egen tråd?).

    Rickard
  • Om ni vill ha möjligheten att labba med min tv och ATV genom att ringa mig låta mig testa olika saker får ni gärna göra detta genom att maila och bestämma en tid.

    Rickard
  • Viktor, jag råkade av misstag radera ditt svar där du berättar hur du fick bukt med problemen genom att fabriksåterställa din Apple TV. Klantigt av mig. Hursom: Tack så mycket för din feedback (även om vi ju helst vill att det ska funka utan så drastiska åtgärder)!

    Harald
  • Tack Rickard, både för input och generöst erbjudande. Hur vi gör med det senare återstår att se men om vi kommer ta vi med kaffe och bulle;)

    Harald
  • Jag har samma problem. Hade det ett tag i höstas/vinttas, sen försvann det. Kommit tillbaks senaste veckan och blivit mycket värre. 10 år gammal LCD-TV, 720p. 50 el 60 Hz spelar ingen roll. En omstart av apple tv löser det för några timmar, sen är problemet tillbaka igen. Inga problem med samma SVT-strömmar när de körs från Plex SVT Plugin på samma Apple TV. Allt annat flyter felfritt, bara SVTplay som laggar.

    Stefan Krantz
  • Har liknande besvär att efter omstart av Apple tv fungerar det i några dagar sedan 'laggar'/hackar bilden medan ljudet fortfarande låter bra. Har upptäckt att det räcker att jag stänger ned själva SVT appen (dubbelklicka på hemknappen och swipa uppåt för att stänga appen) och kör igång den igen för att det ska funka bra igen. Minnesläcka i appen kanske?

    AnnaKarin
  • Har samma problem appletv version 4 och en samsung led 8005 från 2012. Svt är enda appen som strular. Hackar. Enda sättet är att starta om. Börjsr tröttna

    Jonas strömberg
  • Har oxå upplevt detta fenomen att det laggar fast det inte är något fel med bandbredden (har trådat nätverk och 100Mbit).Och bara märkt av detta i SVTPlay inte i någon annan app. Lösningen har varit att starta om ATV.
    Jag upplever det som att felet uppstår när man tittat på tv ett tag. Det kommer alltid en bit in i programmen. Jag har provat att ändra både upplösning och till 50Hz men det uppstår ändå.

    Pär Rommedahl
  • Har problemet också! Det hjälper att avinstallera appen och installera den igen då flyter det på ett tag! Men problemet återkommer efter ett tag!

    Mats Robertson
  • Har samma problem som Stefan Krantz. SVT laggar outhärdligt, efter fabriksåterställning funkar det bra några timmar. Netflix, Vialplay och andra appar funkar utan problem. Börjar bli riktigt frustrerad.

    Tips på åtgärder?

    Jonas Adlergård
  • Stefan, AnnaKarin, Jonas, Pär, Mats, Jonas och alla andra: tack för att ni hjälper oss med feedback!

    Jag upplever själv problemet hemma och håller med, det är frustrerande.

    Här på SVT försöker vi ta reda på och utesluta både orsaker och åtgärder. Vi har kommit fram till följande:

    a) Det drabbar inte enbart SVT Play-appen. En snabb googling visar att användare av olika videoappar på Apple TV har råkat ut för samma fenomen.

    b) Det tycks framförallt uppstå i nya Apple TVs (den version som började säljas i Sverige i oktober 2015).

    c) Det tycks bero på en rad olika faktorer och dessutom olika kombinationer av dessa. Många av dem har nämnts ovan. Det innebär att det är ett svårlöst problem.

    d) De olika trick som nämnts ovan hjälper inte alla och för vissa enbart tillfälligt.

    Vi fortsätter att undersöka problemet och återkommer så snart vi vet mer! Igen: tack för er feedback, den är till stor hjälp!

    Harald
  • Jag lider av samma problem, har 2st Apple TV4.
    Men det är värst på en av dom.
    Hoppas det blir någon förbättring, jobbigt att installera om SVT appen några gånger per dag och så försvinner ju alla sparade favoriter:(

    Micke andersdon
  • AnnaKarins tips är ju guld värt. Det är ju en rätt okej temporär fix på detta problem. Jag visste inte ens att man kunde avsluta en app på det sättet. Tack!

    Rickard
  • Micke, räcker det inte att starta om appen istället för att installera om den? Dvs dubbelklicka på hem-knappen och swipe:a uppåt för att stänga appen?

    Anna-Karin
  • Erik från SVT säger att det är ett allmänt problem i Apple TV. Men hos mig är det bara SVT Play som strular. Jag kör Plex, HBO, TV4 Play och film via iTunes Store. Ingen av dessa uppvisar detta fel. Någon här som har liknande problem i andra appar? Vore intressant för felsökning.

    Markus
  • Har upptäckt att för min del försvinner problemet när jag startar om min Apple-tv.
    Tidigare har det fungerar i strax över en vecka efteråt, sedan kommer problemet tillbaka igen.

    Andreas
  • Anna-Karin
    Dig skulle man vara gift med;) tack.

    Micke
  • @Markus

    Jag har bara problem med Svt Play och använder också netflix, hbo, viaplay, itunes.

    Rickard
  • Något som jag tror hjälper lite grann förutom ovanstående att starta om app och Apple tv är att ta bort favoriter.

    Isabelle Nerelius
  • Har nyligen köpt en apt4 då på den gamla APT3 hackade bilden till var fjärde sekund, från första dagen jag använde den. Bytte under den perioden tv utan bättring. Kopplade in den nya apt med stor förväntan om att bli av med hacket. Ack vad besviken jag blev. För mig är det samma på samtliga appar, oavsett om jag kör ifrån apt direkt eller AirPlay från en padda. Har två olika gen paddor med samma resultat. Har en smarta som jag kör Netflix på och samma film som hackar på apt är ryckfri på smarttv. Vissa filmer på Netflix Funkar utan rycket i bilden med apt!!!! Ngt med upplösning? Jag har inte testat att starta om eller justerat frekvenser eller dyligt. Är bara grymt trött på skiten.

    Robert Strige
  • Uppdatering? Hur går det? Har fortfarande precis samma problem och vill gärna ha en lösning.

    Stefan Krantz
  • Efter att följt tråden här så ändrade jag från 60 till 50 hertz i inställningar i appletv:n.
    Jag behöll upplösningen på max.
    PROBLEMET löst. Inga mer hack i bilden var 4:e sekund. Fan va skönt.
    Tack SVT ni är de enda bland bredbands, streamtjänst och TV-leverantörer som tagit ett grepp om problemet. Det var inte ens ert problem men ni medverakade till att alla mina streamingar mm är ok nu.

    Robert Strige
  • Robert, Stefan, Isabelle, Rickard och alla andra som väntar på en permanent lösning: vi vet nu att problemen ni och andra upplever har två olika orsaker.

    Den ena handlar om Hz och den andra om minnesläckage. Utan att gå in på alla detaljer:

    • Hz-problemet åtgärdas med att ställa om till 50 Hz istället för Auto.

    • Minnesläckaget åtgärdas med att starta om appen. 1) Dubbelklicka på knappen med en tv-symbol på Apple TVns fjärrkontroll. Då visas alla appar du har igång i form av ett bildspel. 2) Välj SVT Play-appen och "swipa" uppåt på fjärrkontrollens touch-yta. Då stängs SVT Play-appen ned och när du startar den igen är problemet förhoppningsvis borta. OBS! OM det kvarstår: starta om Apple TVn.

    Minnesläckaget kan återkomma efter en tids användning och då måste behandlingen upprepas.

    Vi kan inte lova när men hoppas få till en permanent lösning på minnesläckaget så snart som möjligt!

    Harald
  • Gött ställde om till 50hz nu flyter det likt Dalälven tack.

    Mas-Larsson
  • Tack för tipset att ta bort alla Favoriter från SVT Appen! Då dröjer det mycket längre mellan gångerna jag behöver starta om den. Tidigare behövde jag omstart nästan varje dag, nu håller den sig en vecka utan hack.

    Anna-Karin
  • Glada nyheter! Nu har Apple uppdaterat till tvOS 9.2.1 för Apple TV 4 vilket löser problemet med minnesläckage, som alltså har drabbat fler appar än SVT Play.

    Uppgraderingen sker automagiskt OM du inte har stängt av automatiska uppgraderingar.

    Harald
  • Kan någon av alla som skrivit här verifiera att den senaste uppdateringen löst problemet?

    Hans Zetterberg
  • Uppdateringen till tvOS 9.2.1 löste (samma) problem i Youtube-appen för mig. Verkade även som om det var löst i SVT-appen, men sedan någon vecka är det precis likadant igen.

    Youtube och SVT är/var dom enda apparna som hade detta problem hos mig. Youtube fungerar fortfarande perfekt efter 9.2.1

    Anders Nygren
  • För mig är det löst sedan uppdateringen och har inte kommit tillbaka.

    Anna-Karin
  • Kommentar SVT Teknik?? Är buggen kvar eller inte? Verkar råda delade meningar bland era besökare..

    Hans Zetterberg
  • Den bugg vi löst är minnesläckaget, utöver det finns Hz-problemet som vi har löst men som det finns en tillfällig lösning på. Läs mer om det längre upp i den här tråden.

    Tommie
  • Kan bekräfta att felet kvartstår. Tvångsavslutar man appen och startar igen blir det bra. Sedan återkommer felet. Gissar efter vila.

    Skall testa köra med 50Hz. Kommer det få någon annan konsekvens? Jag trodde platta skärmar jobbade med 60 Hz...

    Mvh Olof

    Olof
  • Problemet verkar ha varit tillfälligt för mig. Har sett massor av fotbolls-EM helt utan problem.

    Anders Nygren
  • Kan bara stämma in i att appen nu har blivit instabil. Har tvingats till tvångsavslutning för att komma vidare. Senast i går eftermiddag. Dock upplever jag att hackningarna upphört.

    Jonas Strömberg
  • Har samma problem. Alla videoappar flyter på utom svt. Bilden hakar och ljudet helt galet osynkat.
    Testade stänga ner appen (dubbelklick och swipe uppåt). Detta löste problemet. Återkommer om det uppstår igen.

    Michael
Inlägget är stängt för ytterligare kommentarer.