Kommentaren du söker har flyttats till en ny diskussion, eller är borttagen.

Inget ljud i Safari 11 på Mac

hej, lyssnar dagligen via hemdator på SR, främst klassisk morgon. Onsdag kväll 20/9 fanns inget ljud, testade länkar på sajtkartan med samma resultat. Dock ett par timmar senare var det igång igen. I går torsd. samma sak igen, inte heller ljudfilerna till olika nyhetsinslag fungerade. Ljud från andra hemsidor, ex SVT play fungerar utan problem. Mvh J Munch   Örebro
Visa bästa svaret

Kommentarer

  • Hej Jean!

    Så bra att du skrev hit. Martin Ekeholm på Klassisk morgon skickade oss nämligen den felanmälan du skrivit på Facebook, och vi behöver din hjälp för att förstå vad det är som blivit fel här!

    Har det enbart varit ljudlänkarna som har varit "döda"? Har alltså sajtkartan öppnats och du har kunnat komma in på olika sidor som förväntat - men inte kunnat starta ljudlänkarna?
    Annika Webbmaster
  • Hej Annika. inga problem att komma in på länkarna, men klickar jag på pilarna för att öppna ljudfilerna så börjar den lilla figuren med två staplar som finns högst uppe på sidan att hoppa upp o ner som de skall, -men det hörs inget. mvh  Jean
    jean munch
  • Ok!
    Det är ett bra tecken, eftersom det verkar som om spelaren "nästan" reagerar som den ska...

    Det kan inte vara så enkelt att du dragit ned volymen i spelaren högst uppe på sidan? Att det fungerar ibland och inte ibland skulle i så fall kunna bero på att du får olika spelarinställning beroende av om du besöker oss med http eller https i början av adressen.

    Klicka på högtalaren i högra delen av spelaren och se om det är så enkelt!



    Lycka till!

    Om det inte var så pass enkelt, så vill jag tipsa om att du kanske kan lyssna på våra kanaler med hjälp av direktlänkarna som du hittar här:
    Direktlänkar
    Annika Webbmaster
  • Har exakt samma problem som Jean Munch. Har kollat allt ni föreslagit och mer därtill men inget ljud på SR i alla fall. Detta gäller min MacBook Pro (Sierra), Safari men inte min iMac (Sierra), Safari. I den var ljudet borta någon dag men hördes bra i natt. Enligt kontakter på Facebook hade andra safarianvändare samma problem men inte de som nyttjade exempelvis Chrome.
    Ola Hallberg
  • Tack Oladet var många viktiga pusselbitar!

    Är det Safari 11 på båda dina Mac?

    Jean, vi webbmastrar kan se teknisk information om den webbläsare som använts för att skriva hit, och du ser ut att ha Safari 11 på Mac. Säg till om det inte stämmer!

    Jag ändrar rubriken så att det framgår att det rör Safari. Eftersom det verkar finnas en tydlig koppling mellan webbläsaren och detta fel, vill jag hjälpa andra Safari-användare som drabbats att hitta hit.
    Annika Webbmaster
  • Hello,
    Sorry, borde sagt att jag använder Safari 11 på båda. Men på iMacen hade jag inga problem natten till i dag.
    Regards
    Ola
    Ola Hallberg
  • Tack!
    Intressant att båda fick problem, men att det upphört i den ena ...

    Kan det ha skett någon automatisk uppgradering i den där det åter funkar?

    Hur pass många i ditt nätverk av Mac-användare verkar ha drabbats? Hälften? Fler? Jag har sett ytterligare någon felanmälan som jag tror är samma problem, men det verkar inte vara så utspritt. De vänner och kolleger med privat Mac och de burkar vi har på jobbet har vi inte sett felet hos. Fast jag ska fråga runt mer strukturerat. Om vi kan återskapa felet, ökar förutsättningarna för att vi kan hitta en lösning, oavsett om det är att ändra något hos oss eller att berätta för er lyssnare vilken inställning i Safari som ska ändras.

    När märkte du felet? Uppstod det samtidigt på båda burkarna?
    Annika Webbmaster
  • Hello again
    Ska försöka ta detta punkt för punkt.
    Jag är ensam så något nätverk i egentlig mening kan vi inte tala om. Mina datorer har bluetoothkontakt.
    Jag har för två, tre, kanske fyra veckor sedan hoppat med i iCloud-världen. Något jag själv tänkte kunde påverka under mina egna sök. Men kan inte (med min modesta kunskap) se att så skulle vara fallet.
    När mitt nuvarande problem uppstod (i laptopen) trodde jag att det var samma grej som har drabbat mig förr, på respektive dator. Då löste det sig genom att starta om Safari eller, ännu enklare, genom att helt enkelt byta SR-kanal för att sedan gå på urprungsvalet direkt.
    Den här gången gick inte det (laptopen) och efter några timmas "körning" med omstarter av allt, koll av inställningar, med mera med mera gick jag till min iMac. Den var också tyst. Vad gällde SR – all annan ljudåtergivning från nätet fungerade.
    En säregen grej är att SR några nätter efter ursprungsproblemet fungerade som vanligt men inte dagen därefter. Och inte nu.
    Precis nu upptäcker jag samma sak med min iMac. Den hade ljud i natt men har det inte nu.
    Detta övergår mitt förstånd.
    Hoppas det inte gås över ert!
    Best regards
    Ola Hg
    Ola Hallberg
  • Tack, vi hoppas också att problemet inte övergår vårt förstånd!

    Lars-Gunnar rapporterade igår in ett fel som jag misstänker är samma som ni:
    Problem med att få ljud på min dator

    Även för honom verkar problemet komma och gå:
    Det händer att det plötsligt fungerar efter mycket tryckande och då vet jag inte hur det gick till.

    Tills vi förstår vad som ger detta problem, vill jag tipsa om ett par olika sätt att lyssna utanför Safari.

    Annan webbläsare
    Chrome eller Firefox har vi inte fått samma felrapporter kring, så att testa en annan webbläsare är en god idé.

    Direktlänkar till våra kanaler
    Om man inte kan eller vill installera en annan webbläsare, går det att lyssna på kanalernas ljudströmmar direkt i t ex Itunes. Här finns länkar:
    Direktlänkar

    Program i efterhand
    För efterhandslyssning på ett avsnitt av en programserie går många, men inte alla, program att ladda hem. Vilka program vi har den funktionen för kan ni se här:
    Program att ladda ner/poddradio

    En app för Mac
    Det finns en liten app för Mac som heter Radio i Menyraden. Det är inte vi själva som har utvecklat den, så jag har svårt att ge support kring hur den fungerar. Innehållet är dock vårt!

    Den appen kostar 40 kronor och finns på App store:
    Radio i menyraden

    Hoppas att detta kan vara till hjälp (och - förstås - att vi snart förstår vad som är fel)!
    Annika Webbmaster
  • Jean har hittat ett sätt att komma förbi problemet, fast svaret råkade hamna i en annan tråd, så jag kopierar över det hit:

    Hej Annika. Jag har Safari 11, jag har även flera ljudspelare, mac`s egen quick time player -som uppgraderas per automatik- samt Flash Player och Flip Player. Dessa båda uppdaterade bara för 2 dagar sedan. Men jag har upptäckt något märkligt; -Om man för upp musens pekare (pil) till SR-sajtens övre kant där spelaren finns, dvs den blåa rundeln med två vita lodräta staplar som hoppar upp o ner. Därifrån utgår ju  den blå horisontella linje som markerar det avspelade programmets tidåtgång. Håller inne musens högerknapp och s.a.s "fiska" lite med pekaren... då dyker en vit markör upp, följt av den blå linjen, -och ljudet hoppar igång.    Be inte mig om förklaring. Har haft dator i 20 år, och vet inget liknande.

    Ola:
    Kan du testa Jeans metod, med att högerklicka vid spelaren och se ifall du kan locka fram den vita markören. (Tidslinjen kan ha andra färger än blå hos dig, eftersom det är lite olika på olika kanaler.)

    Det borde gå att se "bollen på tidslinjen" bara genom att hålla muspekaren över, alltså även utan högerklick ...


    Annika Webbmaster
  • Hej,
    Jag har samma problem, men enbart på Macen (sverigesradio.se). Har haft det åtminstone den senaste månaden och en uppgradering till "Mac OS High Sierra" har inte avhjälpt felet.
    Via appen Sveriges Radio Play på min iPad och iPhone fungerar det problemfritt.

    Kan ni lägga ut något meddelande om/när problemet är löst – och hur?

    Tacksam för snar hjälp med detta!
    Jan
    Jan Hagman
  • Hej Jan!

    En av mina vänner med Mac har lyckats återskapa felet och berättar:
    om jag klickar mig bakåt på tidslinjen funkar det!

    (Alltså lite i stil med det Jean rapporterat ovan.)
    Annika Webbmaster
  • Jan:
    Jag har också tipsat om alternativa sätt att lyssna tills vi har löst det, se här.
    Annika Webbmaster
  • Jag prövade Jeans metod och det fungerade!!!
    Men det är ju en åtgärd som behöver användas varje gång, så jag hoppas ni hittar och löser grundproblemet så snart som möjligt.
    Hälsningar
    Jan
    Jan Hagman
  • NOBELPRIS till Jean!!!
    Håller i och för sig med Jan Hagman, även om detta problem synes mig litet.

    Och nu ska jag börja med att försöka göra slut på Microsoft Exchanges mail om "att det inte gick att svara på era mail – de på adressen "no-reply@kundo.se". Jag begriper liksom det.

    Än en gång; hyllning till Jean!
    Best regards
    Ola Hg
    Ola Hallberg
  • Kan ni se till att ni aktivt tillåter autoplay på sverigesradio.se och se om det hjälper?

    https://www.macworld.com/article/3206724/websites/how-to-stop-autoplay-videos-in-safari-11.html

    Karolina Utvecklare
  • Som ni säkert förstår, håller alltså vi på Sveriges Radio med om att det är väldigt bra att Jeans tips funkar, men vill självfallet förstå vad som blir fel till att börja med.

    En av de stora förändringarna i Safari 11 är att webbläsaren kan blockera ljud från att automatiskt spelas upp, och det skulle kunna vara något i den funktionen som tolkar vår spelare fel.
    Annika Webbmaster
  • Hej alla igen. När Annika frågade vilken version av Safari jag hade (11) blev jag lite lömsk... jag gick till safaris inställningar, alltså, ha safari aktiverat, högst upp till vä. på skärmen hittar ni namnet safari. Klicka på namnet Safari, välj inställningar, flera alternativ finns där. Välj alt. Webbplatser. Där kan man välja "tillåt auto-uppspelning".  Obs, under "resans" gång kanske era datorer ber om ert lösen för datorn. Nu funkar ljuduppsp. från SR helt ok. Har nat. testat innan jag skrev detta. Mvh Jean Munch
    jean munch
  • Tack igen både Annika och Jean. Det jag inte begriper dock, är att jag haft samma inställningar i Safari alltsedan jag uppdaterade till 11:an.
    Det fungerar i alla fall!
    Best regards
    Ola Hg
    Ola Hallberg
  • När jag valde inställningen, "tillåt auto-uppspelning" började allt fungera normalt igen.
    Tack för hjälpen med detta!
    Jan H
    Jan Hagman
  • Så bra att den manövern hjälpt er alla!

    Vi ska försöka hitta ett sätt att hjälpa Safari att förstå att det inte alls är en automatisk uppspelning vi ägnar oss åt, utan att våra lyssnare faktiskt vill lyssna smile

    Förhoppningsvis är detta något vi har löst i början av nästa vecka.
    Annika Webbmaster
  • Hej igen!

    Det visade sig vara svårare än vi trodde att få Safari 11 att "förstå oss"... Vi kommer därför att göra en tillfällig lösning, där vi ser till att ni med Safari 11 får upp ett tips om att ändra inställningen för automatisk uppspelning.

    Den inställningen går att ändra på lite olika sätt, men här har jag beskrivit hur man kan göra på ett sätt som jag tycker var enkelt:
    Inget ljud i Safari 11 på Mac

    Tack alla ni som hjälpt oss att förstå vad som blev fel - och trevlig helg!
    Annika Webbmaster
  • Ljudet i Safari 11 har visst funkat! Men inte automatiskt. Jag löste det med att bara sänka ljudet i SR:s meny till längst ner, byta kanal, sen byta kanal igen till den jag vill lyssna på och sen höja ljudet. Inte alls idealiskt eller bra egentligen, men det funka! :)
    Robert
  • Då tycker jag att du ska ändra en enkel inställning (tillåt automatisk uppspelning av ljud), så att det fungerar utan att du behöver in och mixtra med spelaren varje gång.

    Läs mer här:
    Inget ljud i Safari 11 på Mac
    Annika Webbmaster
  • PS: Bra jobbat att du fann ett sätt att lösa det ... Trevlig helg!
    Annika Webbmaster
  • @ Annika Tack, funkar nu som det ska! Trevlig helg med!
    Robert
  • får heller inget ljud på safari
    B
    Berit Sjöberg
  • Hej Berit!

    Har du försökt ändra den inställning vi tipsar om här?
    Inget ljud i Safari 11 på Mac

    Den ändringen (tillåt automatisk uppspelning av ljud) har hjälpt andra med samma problem!
    Annika Webbmaster
  • Finns även problem på Safari version 5.1.10 (!).
    Det kan åtgärdas genom att uppdatera sidan (⌘R) medan buffring pågår.
    Kanske det kan hjälpa att förstå problemet
    Derk
  • Hej Derk!

    Tack för att du ville hjälpa oss med hjälp av denna iakttagelse, som absolut hade kunnat vara relevant! Sedan slutet av september tror jag nog att vi har en rätt bra förståelse för vad som är problemet i Safari 11. De blockerar automatisk uppspelning och först när våra besökare ändrar den inställningen (se här), fungerar det igen.

    Problemet drabbar även andra video- och ljudtjänster, som C More:
    Så tillåter du autoplay i Safari version 11

    Safari är på många vis en trevlig webbläsare, men ljud är inte Safaris bästa gren, tyvärr. Spotify har till exempel inte längre något stöd för Safari + Mac OS enligt uppgift:
    Spotify Web Player No Longer Compatible With Apple's Safari Browser

    Felet du får i Safari version 5.1.10 beror med största sannolikhet på något helt annat. Är det en webbläsare du använder aktivt så hjälper vi gärna till och felsöker. (Som administratör i forumet ser jag lite data om den webbläsare du använde när du skrev till oss, och det var ju inte Safari från 2013 ...)

    Trevlig helg!
    Annika Webbmaster

Kommentera eller skriv ett nytt inlägg

Ditt namn och inlägg kan bli synligt för alla.
Din e-post visas aldrig publikt. Läs vår policy