To latest comment

Medals and badges have disappeared

Hello, I haven't logged in 2 months and now got a new computer. I just logged in an all of my explorer mode medals have disappeared? The game even acts as if it's my first time in the explorer mode with an explanative pop-up. My badges have disappeared as well. Could you fix that please?!
KimJLATS

Comments

  • Hi Kim,

    That sounds strange. The badges should still be there, are you logging in on another account?

    Cheers
    Filip
  • I've managed to find a way around. (Thanks for the reply anyway) The issue was due to my clumsiness but also to malfunction of the website: I was trying to play from a new computer and accidentally created a new account instead of logging in. I didn't realize then that I also was "logging" with a more recent email address than the original. So that's on me, though at no point in the process did the website tell me that the username was already taken, so the two accounts kinda were twins. Once I noticed that I got the email wrong, I changed parameters and I could log in with the other 😀 And could delete its twin!
    KimJLATS
  • Ah I see!

    Yeah I will raise that further with the same usernames. Glad it was resolved!

    Cheers
    Filip
  • Hey, im wondering why im am not getting my badges in exploration mode after completing different continents like Oceania
    harald
  • Hi,

    There is usually a delay in the Badges in Explorer Mode, so it should be sorted the next day 🙂
    Filip

Add your comment or create a new post

Your name and post can be seen by everyone.Your e-mail will never be shown publicly.