To latest comment

"FAILED TO LOAD THE PANORAMA AT THIS ROUND.TRY AGAIN."

Sometimes in the middle of the game street view from google maps could not be loaded, the screen turned whited and said "FAILED TO LOAD THE PANORAMA AT THIS ROUND.TRY AGAIN.". This happened many times and the only way to solve this is to close my browser and launch it again.

Comments

  • Hi tst5,

    Sorry about that, what happens if you click the try again button, nothing? That should load a new panorama..
    When you close the browser and open it up again, do you resume the same game and that works or do you start a new game?

    thanks and sorry for the inconvenience!
    Mikael
  • Same happened to my sister when we were playing a challenge. She tried another browser but the problem persisted.
    Tony Pelletier
  • I had the same problem.  We have multiple family members with their own accounts. The first account, mine, we just guessed hoping that the next round would give us a picture, but all five rounds failed to load a panorama.  The second account, my son's did the same thing.   We even tried two different browsers.  We tried to view GeoGuesser in the United States and Famous Places.  We also tried restarting our computer.  Seems to be an issue with the server.
    Steve
  • I am having the same problem.  I can play maybe two rounds and then it freezes.  This happens repeatedly.  I am using the free one game per 24 hours version.
    Robert K
  • Got the same probleme and I have the paying option....
    Victor L
  • Hi, I've got the same problem. I reloaded it a few times but it was still broken. In the developer tools it shows up as a 404.

    Here's the curl.

    curl 'https://geo0.ggpht.com/cbk?cb_client=apiv3&panoid=tY3hbLZ2Dm5P7y_NB-l6yA&output=tile&x=0&y=0&zoom=0&nbt&fover=2' \
    -H 'authority: geo0.ggpht.com' \
    -H 'sec-ch-ua: "Google Chrome";v="87", "\"Not;A\\Brand";v="99", "Chromium";v="87"' \
    -H 'origin: https://www.geoguessr.com' \
    -H 'sec-ch-ua-mobile: ?0' \
    -H 'user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.67 Safari/537.36' \
    -H 'dnt: 1' \
    -H 'accept: image/avif,image/webp,image/apng,image/*,*/*;q=0.8' \
    -H 'x-client-data: CJe2yQEIorbJAQjBtskBCKmdygEI67jKAQisx8oBCPXHygEIo83KAQjc1coBCPfVygEI7ZjLAQiOmssBCJeaywEY3LjKARiKwcoB' \
    -H 'sec-fetch-site: cross-site' \
    -H 'sec-fetch-mode: cors' \
    -H 'sec-fetch-dest: image' \
    -H 'referer: https://www.geoguessr.com/' \
    -H 'accept-language: en-US,en;q=0.9' \
    --compressed
    Paul
  • Same problem here. Neither 'Try again' nor refreshing the page helps. The game is just stuck and we need to start a new one, which is especially disappointing when playing the streak mode. That's not what I got a premium account for 🙁

    Sofie
  • Google probably removed something on Street View which broke the game. If you could skip the round to see where is the location then we could confirm that, sadly it seems not possible.
    Mapper
  • Same happens to me on two different streak games (at streak 11 and 8 respectively). Pretty annoying. I am a pro member since yesterday and this is quite disappointing. Add to that numerous black screens of the death...

    I really like this game and i appreciate the good work of your team on it... but that will surely lead me to stop my subscription before day 10...
    Snig
  • Sadly the black screen issue is independent to the game as Google can remove data at any time (notably user-made photospheres). Can't do much about that. It will heavily depend of the played map too, some maps are never maintained by their creators and that's not the devs who have to maintain them (otherwise they would need hundreds of them to check all the maps).

    The devs are currently looking for the wrong location problem, looks like they may have found the origin so hopefully it should be fixed soon.
    Mapper
  • I just had a black screen on Country Streak, guessed a random place, clicked the flag, and there was a good link with Google, on google nothing was removed. (that was there : https://www.google.com/maps/@49.226007,17.6633543,3a,70.3y,121.09h,88.1t/data=!3m6!1e1!3m4!1ssJTAqmK3Dl1dRLpTQj-ayg!2e0!7i13312!8i6656
    So i'm not sure the problem comes from Google.
    In country streak mode, there is so much black screen and "failed to load the panorama" these days.
    I can't have more than five locations without this bug, that's unplayable.It's clearly new on this map, there was 0 bugs for me some weeks ago, i could play for hours without problem.
    JH
  • Just want to add urgency to this, the same happened to me. 

    Noi Noi
  • And me too
    Veronica
  • Got my 42 streak ruined by that...
    Tried to reach the 50...
    Will it work again after a while or is my streak definitly ruined?
    A.D.
  • We investigated the issue with one of the devs and found that Google is the source of it. Their API stopped returning the expected data when loading a location using the panorama ID (ID= identification number, which is unique to each panorama).

    The ID is not supposed to change as it is used to select a specific panorama but for some reason Google changed a few of them. This is obviously not a good thing as it breaks everything and this is why suddenly many failures are happening.

    That's the problem when you have to deal with another company: you never know what they're going to do or if everything will be fine... So now they're working on a way to counter this problem as the whole database of locations used by the game is compromised. They need to check all the IDs to validate them (or correct them). Hopefully a fix will come soon, it may unlock the streaks that are currently being blocked by the problem.
    Mapper
  • If you still have your game running you can try to refresh the page and hopefully it loads again. Sorry for the inconvenience!
    Jesper
  • It seems to have done the trick. I just tried to load a dozen unfinished games from yesterday and they all loaded perfectly. Thank you!
    Frederic
  • Mine does not :-(
    Christoph Hebenstreit
  • I was playing Daily Challenge, and got a 'panorama not loaded' notification, but it included "since the panorama did not load, everyone on this round will get zero points". I thought, fair enough, error, but the playing field is levelled for everyone. however, when I looked at the high score list after the game, 200+ players got over 20000 points. That should be impossible, correct?
      I must admit that people who consistently get perfect 25000 scores on Daily Challenge seem to be hacking somehow. Bad players, you know who you are!
    Karl
  • Yeah as several people have no pointed out the recent change of giving people zero points on these rounds where the panorama fails to load is really dumb. Today I was doing the DC and had found the intersection I was at. When I returned to start to pinpoint I got the failed to load message and got zero points on the round. Of course the leaderboard was full of people who did fine on that round. Please just revert whatever you did a few weeks back, it has ruined 3 separate DCs for me so far.
    Tobin
  • btw turns out the old advice works even for this new message. just refresh the page and you will probably get another crack at the round. still no idea why the message has been changed to the no points things, but just reload the page.
    Tobin
  • Playing the "Daily Challenge", recieved the "Failed to load the Panorama..." 4 out of the 5 attempts. At least 2 "failed to load panamora" scenes had so few clues or were so vague landscapes, I'd probably not be close; but I'd like the full 3 minutes to attempt to score more than zero.  

    Bug seems tooccur after returning to start and attempting to move around.
    Chris
  • This happened on today's Daily Challenge on round 3 (Mongolia) if that's helpful. It's happened several times on Daily Challenges in the last few days. GeoGuesser should handle this issue more gracefully than kicking you out of the round.
    Elaine
  • Yeah seems like it happens pretty consistently when you return to start on the DC. Return to start has been buggy for a long time sadly.
    Tobin
  • For the last couple of days I've had issues with the Daily Challenge.  Each morning when I open it somehow the first round has already been answered.  Often in the middle of the ocean which doesn't help my score 🙁
    I also have frequently had the panorama failed to load message, also saying that all players will get a zero score. But others have played that round and scored appropriately, whereas I can't and do indeed get awarded zero points.

    Sally Drager
  • Playing Daily Challenge. I get that there have been technical difficulties, sounds like google is part of the problem, but when I get the notice that "panorama failed to load", it also states that "no one will get points for that round". and yet players getting more than 20,000 are obviously getting exactly that. C'mon guys, what gives?
    Karl
  • So I tried refreshing and no go. now what?
    Karl
  • Had the same problem in today`s challenge, in the second map. After returning to starting point, the screen went black or the "panorama failed to load" error popped up. As mentioned, a workaround that worked for me is to refresh the browser, this should bring back the map even if the screen with the "0 points message" already appeared! Just dont click the "skip to next round" button. 😀
    I noticed though that the timer gets reset then, this is obviously not fair. Hopefully this gets fixed soon.
    Florian
  • You can reset the timer for any round by reloading the page. It's a long-standing design oversight.
    Tobin
  • Pasting this from a thread I was about to create before I saw this one...

    I was in the final rounds of a Battle Royale match and was moving around in Montenegro and suddenly ran into this:



    It then didn't let me do anything. A failure to load a specific part of street view shouldn't prevent me from moving or guessing entirely. Others were able to guess still, so it seemed to only affect me.

    This was the URL:

    https://www.geoguessr.com/battle-royale/577ef2f2-625f-46ad-a2f2-075318513623

    Browser is Firefox 84.0.1 (64-bit).

    no
  • I have a black screen.  If I try to do anything, I get the "Failed to load ..." message.  I am on a Country Streak of over 220.  I am not pleased.  This is not the first time I have encountered this error.  It appears from this thread that this has been a problem for some months.  If we pay a subscription I think it is reasonable to expect better than this.
    John Pedley
  • This "FAILED TO LOAD THE PANORAMA AT THIS ROUND" is starting to happen to me at almost every daily challenge - I am disappointed as I pay a subscription and its just taking the fun out of every game now. So I only can score for 4 out of teh five games.  I always try and put something on a map - as it it does occur and yo wait for the timer to count down it recognises where you last were.

    🙁


    Dono
  • I have the same problem. can't get done with USA Challange since it always fails when going back to spawn
    Filip Andre Valskraa
  • I've been playing USA this morning and I keep getting this error. Go down the road from your spawn point, click "back to spawn", then move about 4 to 6 times and I get the message. This is happening every single time, I'm yet to have a round where it didn't happen.
    Ryan
  • Wow, that was exactly what happened to me!
    Filip Andre Valskraa
  • Happened three times in a row today, and I'm a paying member :/ Can someone help? It ruined our game unfortunately, because it didn't respawn in the same place after that, so we kept getting close to a solve only for it to crash.
    Sophie
  • It just happened to me too, three times in a row. Each time the same scenario: I'm in the round for a couple minutes, moving forward towards a direction. After a while I go back to the start point. And then after 2 or 3 moves, I get the error message. When I click on the Try again button, it starts a new round.
    I played five free round yesterday, had not problem. Five more today, without problem. Then I payed a yearly subscription, and since then, I couldn't finish any round because of that problem.
    Please help, I'm very disappointed of having paid the Pro subscription.
    Hervé
  • This issue is still happening...
    I got the error 3 times during the same run...its really annoying. I am 90% sure where I am and it loads a new map...
    Its ridiculous...
    NotMeAtAll
  • The same problem while playing. It started recently. Mostly the game is OK, but getting this annoying error in 1-2 rounds out of 5. Clicking on the button, it loads NEW map! Exactly when I'm close to solving the old one!

    Very annoying, please fix!!! I'm a paying customer.

    (reopening the browser and reloading windows already tried - it's Chrome on Win 10).
    Pavel
  • I keep getting this issue too. I am trying to get full score on Norway and every time I’m near pinpointing it I get this error. I am able to click try again but that just loads up a new round. Very annoying.
    Eyyrin
  • Just want to throw my hat in the ring and say it's happening to me too.

    Once yesterday and today (just playing the regular US map).
    Tom
  • Yep, happened to me again yesterday playing France, and today playing a Diverse World challenge with friends. We all encountered the issue.
    Maimai
  • the lad from up north
  • Just FYI, refreshing the browser (and not clicking the button) did fix it for me.
    Tom
  • This had never happened to me before a day or so ago. Now it's happening on almost every round. And this is Google's fault?? I can't get through a game now.
    John

Add your comment or create a new post

Your name and post can be seen by everyone.Your e-mail will never be shown publicly.