Black screen/slow loading

Hi,
It takes too much to load images and sometimes it's just black screen. I googled my problem and found some solutions those worked for some people but disabling hardware acceleration, using different browsers, clearing caches didn't work for me. My internet connection and PC specs are relatively good. I haven't played for a few months and I've had no issues then. So I reckon it's something about these new changes.
I hope you can help me, thank you in advance.

Comments

  • Hi,

    It is not related to changes made to the site. Black screens is something we have removed the last month. Unless its not working with the troubleshooting tips its most likely a device issue. Perhaps changing the DNS server to Googles might resolve it.
    Filip
  • I tried 10+ DNS servers but none of them worked. I want to play with pro version but it is maddening to play this way. Also I figured that the loading process of images doesn't start. I mean it doesn't struggle to load images, it just does not start. I have no idea how it works but I thought this'd maybe help you to give any instruction.
    Thanks.
    Eren
  • Hard to say what the issue and rootcause is if it the same after the troubleshooting tips. Not much more we can do from our end since its most likely a local issue.
    Filip
  • Okay then, thank you anyways. I hope it fixes by itself.
    Eren
  • Do you have the same problem on Google Maps when using Street View?
    Mapper

Add your comment or create a new post

Your name and post can be seen by everyone.Your e-mail will never be shown publicly.