Battle Royale is not loading

Whenever I click on play (country battle), all I get is "Connecting to Game". It never proceeds past this point. Every other game mode works fine.
GeoHaz89

Comments

  • Hi,

    Strange, I tried from my end and it worked fine. Do you still experience this issue when you try to play BR Country?

    KR
    Filip
    Filip
  • I do indeed. Just tried it again now.
    GeoHaz89
  • Alright that is strange. Have you tried some of the troubleshooting we have in this guide and see if its the same issue?

    If it does not work, send me an email to subscription@geoguessr.com with a screen-recording and you can also provide the events in Inspect/Console in Chrome and send on as well:


    Filip
  • I can confirm that Distance BR doesn't work and the regular Country BR mode loads whenever I try to play a Distance BR game.
    Frederic
  • Just wanted to update and say it seems to be working again. I was able to play two games in a row without any issues.
    Frederic
  • Great, glad it was resolved! Thanks for updating Frederic!

    Let me know in case you encounter it again and if you can provide the URL it would be great. Im trying to replicate it from my end as well.

    KR
    Filip
    Filip
  • Hi! i am having what seem to be the same issue now, but cannot find any more info on this anywhere else, is it still an issue for anyone else? And how do you fix this?
    Anders
  • Hard to say since there is no account on this email I cannot see if there is some account-issue or not.
    Filip

Add your comment or create a new post

Your name and post can be seen by everyone.Your e-mail will never be shown publicly.